Support Board
Date/Time: Fri, 22 Nov 2024 04:22:45 +0000
Post From: Version 2151 Available: Foundation For Millisecond/Microsecond Timestamping
[2020-08-23 18:16:10] |
BrMa - Posts: 80 |
Dear Sierra Chart Engineering, first of all thank you for the update and the intended increase in precision out of a timing perspective. I worked through it today and adapted my code. When doing this I approached three minor topics I'd like to address here and ask you for updates: 1) In my code I'm using sc.GetEndingDateTimeForBarIndex() which returns a double value representing the ending Date-Time of a chart bar specified by its bar index. Isn't that inconsistent? From my point of view the interface should return a consistent data-type representing date/time information - whatever you decide to go for. sc.GetTradingDayStartDateTimeOfBarForChart() is affected as well. For the time being I'm passing the double value returned to the SCDateTimeMS()-constructor which seems to me to be a multiple convert SCDateTime (I guess used internally) -> double -> SCDateTimeMS!? scdatetime.h says SCDateTimeMS is derived from SCDateTime - just adapted methods for SCDateTimeMS... so it would be much more efficient to have the "original" data-type for further processing... 2) In post #43 you mentioned that the following text string members are now changed to functions but documentation lacks information or is at the wrong place: SCString sc.VersionNumber();
Marked as type function but still in the secion Variables and Arrays - not FunctionsSCString sc.UserName();
Marked as Read-only Character string and still in the secion Variables and Arrays - not FunctionsSCString sc.DataFilesFolder();
Marked as Read-only SCString variable and still in the secion Variables and Arrays - not FunctionsSCString sc.ServiceCodeForSelectedDataTradingService();
Marked as Read-only SCString variable and still in the secion Variables and Arrays - not FunctionsSCString sc.SCDataFeedSymbol();
Marked as Read-only SCString variable and still in the secion Variables and Arrays - not FunctionsSCString sc.CustomAffiliateCode();
Marked as Read-only SCString variable and still in the secion Variables and Arrays - not FunctionsSCString sc.ChartbookName();
Marked as Read-only SCString variable and still in the secion Variables and Arrays - not FunctionsSCString sc.ChartTextFont();
Marked as Read-only string variable and still in the secion Variables and Arrays - not Functions3) As with normal coding guidelines and also your naming conventions for functions up to now I'd suggest to add a "get" in front of the function name - e.g.: sc.getVersionNumber() or sc.getUserName() Date Time Of Last Edit: 2020-08-24 06:18:13
|